[Tinyos-help] About pogram error 57 in usip when trying to program a mote with cywin: Problem solved

barbaran barbaran at lcc.uma.es
Sun Nov 14 01:40:19 PST 2010


Hi all, 

Around March of this year I posted a problem when trying to program a mote
using TinyOS installed over cygwin, and I got error 57 when using uisp.
Other folks told me that they had the same problem even in Windows XP or 7,
but no one solution came up, so in that days a take the option of
installing VMware, but now I dont want to use it anymore, so I searched
into avr forums, and it seems that installing a new version of cygwin
everything would be all right. 

Yesterday I tried again, using Windows 7, so... firstly, I installed
tinyos using cygwin and rpms available, from the tinyos website, I got the
error 57 problem when trying to test Blink application into a micaZ. Then,
without uninstalling anything, I downloaded a new version cygwin and
installed it over the other one, after a while installing (as the
installation program download every cygwin's package separately) I didn't
notice any difference with cygwin and neither with tinyos as all the
packages were still installed, and when I tried to program, everything
works fine!! 

So, this e-mail it is only for those who get the error 57 when trying to
program a sensor, so they only need to update the cygwin, I think the
reason is that some windows update is creating some problem with the tinyos
website cygwin version, so yu only need to update it to the latest.

I would also propose to the tinyos website administrator to change the
cygwin installer reference, or at least put a comment about this, because
this problem could be causing some people that want to use TinyOS into
Windows to use other o.s. or have a mess trying to install vmware or even
installing a Linux.

Regards,

Javier Barbarán
barbaran at lcc.uma.es


More information about the Tinyos-help mailing list