[Tinyos-help] Errors in starting up BLIP

Varun Jain varun at spiderbox.com.au
Wed Feb 25 18:58:41 PST 2009


Hi Stephen,

 

I have been working on Sensor networks and have been able to build an
application (Meter Reading) for 25 nodes. I have started working on Ipv6
now. I was following the Readme instructions at:
http://smote.cs.berkeley.edu:8000/tracenv/browser/code/b6lowpan/trunk/RE
ADME

 

I have the libmote.a built correctly in  /support/sdk/c/sf 

 

I was trying to do the next step of setting up the environment variables
but I do not understand some things:

You ask to set up the following variables

export LOWPAN_ROOT=~/svn/code/b6lowpan/

export TOSMAKE_PATH="$LOWPAN_ROOT/support/make"

 

Whereas in a script, I already have the following variables set up:

export TOSROOT="/opt/tinyos-2.x"

export MAKERULES="$TOSROOT/support/make/Makerules"

 

 

Are the variables said by you different, because you ask to set up to
the top level "blip" directory, which is this "top level  directory"
that you are referring to, isn't it the TOSROOT???

 

 

If I am correct with my environment variables, then while building the
blip directory, I get following errors.

 

varun at varunjain /opt/tinyos-2.x/support/sdk/c/blip

$ make all

cd lib6lowpan && make

make[1]: Entering directory
`/opt/tinyos-2.x/support/sdk/c/blip/lib6lowpan'

gcc -o lib6lowpan.o lib6lowpan.c -DPC -g -I../include/ -c

In file included from lib6lowpan.c:23:

../include/ip.h:31:26: linux/if_tun.h: No such file or directory

In file included from lib6lowpan.c:23:

../include/ip.h:77: error: field `ip6_src' has incomplete type

../include/ip.h:78: error: field `ip6_dst' has incomplete type

../include/ip.h:258: error: field `pi' has incomplete type

make[1]: *** [lib6lowpan.o] Error 1

make[1]: Leaving directory
`/opt/tinyos-2.x/support/sdk/c/blip/lib6lowpan'

make: *** [all] Error 2

 

This error is understandable as I am running cygwin, what should I
replace it with???

Environment: Cygwin, TInyOS-2.0.2, my own platform similar to micaz

 

 

What am I doing wrong??? Any hint would be great!!!!!!!!!!!

 

Cheers,

 

Varun Jain

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://www.millennium.berkeley.edu/pipermail/tinyos-help/attachments/20090226/77443391/attachment.htm 


More information about the Tinyos-help mailing list