[Tinyos-help] Using Block application to test flash memory IO

JD hinomura.yo at gmail.com
Wed Feb 25 08:52:12 PST 2009


Hi all,

A precision about our problem writing/reading flash memory.
We get the following error message in wsim.log

wsn430:devices: read data on radio while not in SPI mode ?
msp430:usart0: SPI data RX but not in receive enable state

we think that our flash memory chip cannot be accessed properly due to
collisions with other perpherals ( radio chip) which might be in SPI master
mode ...

How could we set our flash memory in SPI mode  ? Or disable the SPI mode for
CC1100 (radio chip) ?

2009/2/24 JD <hinomura.yo at gmail.com>

> Hi guys,
>
> I'm using TinyOS 2.0 svn sources and I've adapted telosb's stm25p driver (
> flash memory ) for our wsn430 platform.
> For now, when we execute the apps/tests/storage/Block, we only get the led2
> ( blue) switched on...not blinking...
> In theory we should have  the led2 ( blue ) blinking , then led1 must be On
> to show success.
>
> We think that it might be the event BlockWrite.eraseDone(error_t result)
> that is not fired.
> We also can say that telosb and wsn430 have the same msp430 chip and same
> memory flash chip. Even the pins assignments are identical.
>
> Any idea would be welcome.
>
> Cheers,
>
> JD
> ----------------------------------------------------
> "If A is a success in life, then A equals x plus y plus z. Work is x; y is
> play; and z is keeping your mouth shut. " A.Einstein
>



-- 
----------------------------------------------------
"If A is a success in life, then A equals x plus y plus z. Work is x; y is
play; and z is keeping your mouth shut. " A.Einstein
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://www.millennium.berkeley.edu/pipermail/tinyos-help/attachments/20090225/c142a808/attachment-0001.htm 


More information about the Tinyos-help mailing list