[Tinyos-help] Deluge T2 problem on a NEW platform

Mehmet Akif Antepli akifantepli at gmail.com
Fri Feb 13 14:00:33 PST 2009


Hi Razvan,

First of all, thanks for your reply and suggestion.

On Fri, Feb 13, 2009 at 10:40 PM, Razvan Musaloiu-E. <razvanm at cs.jhu.edu>wrote:

> Quick question: for Sensenode do you upload the image doing 'make telosb
> install'?


Actually, the command;
"make telosb install"
does not work. Thus, I used the following command to load GoldenImage into
'Sensenode':

" /usr/local/msp430/bin/msp430-bsl -r -e -I --invert-reset --invert-test -c
/dev/ttyUSB0 -p
/opt/tinyos-2.1.0/apps/tests/deluge/GoldenImage/build/telosb/main.ihex"

Note: if you run the latest CVS (highly recommended :D) you should use the
> apps/tests/deluge/Basestation.


I work with XubunTOS-2.1.0 and i want to use tinyos-tools in XubunTOS-2.1.0
in order to  not to make things  complicated.  Otherwise, after installing
XubunTOS-2.1.0, i should download tinyos-2.x from CVS, then configure the
system... What i want is to establish development environment in one step
(maybe two :-)). But it seems that even XubunTOS-2.1.0 lacks the whole
capability. If it doesn't work with tinyos-tools in  XubunTOS-2.1.0, i
promise i will try the latest CVS :-)

I think the problem might be in the tosboot (tos/lib/tosboot). There there
> is some code that is responsible with reading stuff the external flash and
> write it on the internal one. The code responsible with this is in
> tos/lib/tosboot/stm25p for telos. The main component for tosboot is
> TOSBootM.nc. I usually debug it using the leds.


I will look the files you mentioned above, it seems to be a good hint.

Thanks for your help,

All the best!


Mehmet Akif Antepli
Graduate Student
Dept. of Electrical-Electronics Eng.
METU
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://www.millennium.berkeley.edu/pipermail/tinyos-help/attachments/20090214/7e2a24a4/attachment.htm 


More information about the Tinyos-help mailing list