[Tinyos-help] Using Matlab with Tinyos

Alan Wade alan.wade at keble.ox.ac.uk
Tue Feb 10 07:41:34 PST 2009


Hi,

I am trying to communicate with my motes through Matlab and have tried 
to follow the set-up tutorial here:

http://www.tinyos.net/tinyos-1.x/tools/matlab/doc/faq.html

I have compiled the tools in java/net/tinyos/matlab in the Cygwin window 
without error, apart from MatlabClock.java having a depreciated API, 
which from reading through archived messages I believe to be insignificant.

However defineTOSEnvironment.m tries to read in the folders: 
.../tinyos-1.x/tools/matlab/apps, .../tinyos-1.x/tools/matlab/lib and 
.../tinyos-1.x/tools/matlab/tools; all of which did not exist on my 
system. The other folders it calls in the 'matlab' directory, 'comm' and 
'util' do exist and called fine. I tried to create folders with the 
names of the missing folders, and then Matlab started up fine and loaded 
defineTOSEnviroment with no errors, returning groupID=7D (as I had 
re-written defineTOSEnvironment to this groupID I am using).

However when I try to connect to the mote on my serial board which is 
running TOSBase, using the command in the tutorial: 
connect('serial at COM1:57600'); I get the following errors:

getenv JNI library not found. Env.getenv will not work
(please consult installation directions in
tinyos-1.x/tools/java/net/tinyos/util/Env.INSTALL)
??? Reference to non-existent field 'GROUP_ID'.

Error in ==> defineComm at 21
disp(['groupID = ' dec2hex(COMM.GROUP_ID)])

Error in ==> connect at 20
    defineComm

I was wondering if anyone could provide any advice on what may be my 
problem.

Thank You In Advance,
Alan


More information about the Tinyos-help mailing list