[Tinyos-help] Over-the-Air-Programming

Asier Arruti asarruti at yahoo.com
Thu Feb 28 03:56:38 PST 2008


"There is no response from the base
station" means the MoteConfig has not been able to receive heartbeat
messages from the base station.
Several questions:
1.Which MIB board are you using and what COM port is assigned to it?

Sorry, I forgot putting it. I amusing MIB520, but I have tried with the MIB510 too. The COM port is COM3. Ihave selected these options in Settings/Interface Board.
2.Are you using any USB-Serial adapter?

Yes, I am using a Conceptronic
USB-Serial Adapter.
3.Which application did you program into the base station Mote? (one that isattached to the MIB board)?

I have programmed the XMeshBase
application in the base station mote, with OTAP option disabled, and the XMesh
application in the other motes with OTAP option enabled.
4. Before attempting to OTAP, were youable to receive/view data in MoteView from the remote Motes and verifycommunication?

Hum, after attempting to OTAP, I do not receive any kind of message. Before this, I didn't try it, but previously, I used MoteView and it worked as desired; so, I don't know which the problem can be.
 
Regards,
Giri

Thanks again

Regards,

Asier Arruti




----- Original Message ----
From: Giri Baleri <mbaleri at xbow.com>
To: Asier Arruti <asarruti at yahoo.com>
Cc: tinyos-help at millennium.berkeley.edu
Sent: Wednesday, February 27, 2008 5:30:27 PM
Subject: RE: [Tinyos-help] Over-the-Air-Programming

 DIV {
MARGIN:0px;}
"There is no response from the base station" means the 
MoteConfig has not been able to receive heartbeat messages from the base 
station.
Several questions:
1. Which MIB board are you using and what COM port is 
assigned to it?
2. Are you using any USB-Serial 
adapter?
3. Which application did you program into the base 
station Mote? (one that is attached to the MIB board)?
4. Before attempting to OTAP, were you able to 
receive/view data in MoteView from the remote Motes and verify 
communication?
 
Regards,
Giri

From: tinyos-help-bounces at millennium.berkeley.edu [mailto:tinyos-help-bounces at millennium.berkeley.edu] On Behalf Of Asier Arruti
Sent: Wednesday, February 27, 2008 8:03 AM
To: tinyos-help at millennium.berkeley.edu
Subject: [Tinyos-help] Over-the-Air-Programming



Hi,

I am trying to programme the MicaZ motes over-the-air, because OEM Edition must be soldered to use it (and it is always difficult to get things working as desired the first time). I have followed all the steps that are explained in "MoteConfig User's Manual" document (http://www.xbow.com/support/support_pdf_files/moteconfig_users_manual.pdf), but my base station does not detect the turned-on motes (paragraph 5.2, page 16).
The message it shows is "There is no response from the base station. Please check your connections, verify that switch SW2 is set to the OFF position and click Search again". 
I have checked that switch, the COM ports (they seem to be working fine because I can programme the Motes normally) but I get the same message  over and over again. Possibly, I am doing something dumb, so could anybody help me solve this problem?

Thanks in advance,

Asier Arruti



Be a better friend, newshound, and know-it-all with Yahoo! Mobile. Try 
it now.





      ____________________________________________________________________________________
Never miss a thing.  Make Yahoo your home page. 
http://www.yahoo.com/r/hs
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://www.millennium.berkeley.edu/pipermail/tinyos-help/attachments/20080228/9c20d854/attachment.htm


More information about the Tinyos-help mailing list