[Tinyos-help] some questiones about Xserve

Yong, Chee Yeew Chee-Yeew.Yong at thalesgroup.com
Thu Feb 21 00:18:25 PST 2008


I have not used the web server option before, but I'll try to help.
 
1) Which 'base station unit' are you using? MIB510 or MIB600?
2) a) If MIB510, does your PC or laptop have a serial port?
2) b) If MIB600, you need to change the arguments to xserve to point to that
device's IP address.
 
Chee

-----Original Message-----
From: tinyos-help-bounces at millennium.berkeley.edu
[mailto:tinyos-help-bounces at millennium.berkeley.edu]On Behalf Of Yu Qun
Sent: 21 February 2008 06:55
To: tinyos-help at millennium.berkeley.edu
Subject: [Tinyos-help] some questiones about Xserve



Hi everyone:
 
Hope to gain some warm responses from you!
 
I encountered a problem after intalling MoteWorks, I want to visit the
Webside such as http://localhost:8080 <http://localhost:8080/>  through
Xserve WEB Interface as said in the MoteWorks Guide. Before visiting this
URL, the xserve must be started. the corresponding command in Cygwin is -h,
but here always appears the following output:
 
$ xserve -h
[2008/02/21 01:40:15]  xdebug: could not open log file
/opt/MoteWorks/tools/xser
ve/bin/logs/xserve_log.txt: No such file or directory
XSERVE 2.0.E: $Id: xserve.c,v 1.8.2.3 <http://1.8.2.3>  2007/02/02 17:45:01
rkapur Exp $
Using params: [xml raw] [xml parsed] [xml converted] [server port=9001]
Opening serial device: /dev/ttyS0 @ 57600
[2008/02/21 01:40:18]  xserve: Couldn't open serial port /dev/ttyS0:57600
XMonitor: XServ failure.
Evaluating process exit...
Exit status - Application Level Exit. No restart requested.
Signal Status - Normal.
wait: No error
 
So I want to ask some quesiones based on the above output:
 
1.What does the meaning of this output stand for? it seems that the
xserve.exe under the path.//opt/MoteWorks/tools/xserve/bin/bin, has not been
run.
 
2.what is /dev/ttyS0:57600, how to use it?
 
3.How to start Xserve normally in MoteWorks with the Cygwin command to visit
the web interface provided by Xserve?
 
4.is <http://4.is>  there a special CygWin.dll for Xserve? if so, how to
gain it? How to configure it in the MoteView and MoteWork for normal
operation?
 
Looking forwark for your help and reply!! Thank you very much!
 
Best Regards;

Maggie


*******************************************************************************
Please consider the environment before printing this email.
*******************************************************************************
This email and any files transmitted with it are intended solely for the use of
the individual or entity to whom they are addressed and may not be divulged to
any third party without the express permission of the originator.  Any views
expressed in this message are those of the individual sender, except where the
sender specifically states them to be the views of Thales Research & Technology
(UK) Limited.
*******************************************************************************

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://www.millennium.berkeley.edu/pipermail/tinyos-help/attachments/20080221/7de50840/attachment.htm


More information about the Tinyos-help mailing list