[Tinyos-help] Compilation problem with iris motes....but works finewith micaz

Michael Schippling schip at santafe.edu
Wed Feb 20 10:50:59 PST 2008


I don't know about IRIS, but the complaints seem to be about
defines for the ATMEGA ports and pins, plus a couple of UART
methods. Does the IRIS use an Atmel chip? If so there may be
something screwy in the platform configuration, if not you
have a bunch of UART programming to do since the ports'n'pins
are likely to be entirely different.

MS

Murtuza wrote:
> Sorry for the incomplete mail.
> 
> here is the output....
> 
> Application Description : This application programs the GPS motes to 
> receive GPS information. I send a command to these motes through base 
> station and they send me the continuous GPS data. This application works 
> find on micaz. Its the compilation with iris that gives error. I even 
> noticed that it has the same problem with micazc motes. May be iris and 
> micazc share the same libraries or tools etc.
> 
> I compiled using "make iris" command. My application is in the 
> /opt/MoteWorks/apps/general directory. The other example codes in the 
> MoteWorks work fine for iris. The installation is fine as I have no 
> problem with other example codes. This application of mine shows error 
> associated with the SODebug.h file found in /sensorboards/mts400. The 
> mts400 in the MoteWorks directory doesnt actually have SODebug.h file in 
> it. I am using the mts400 file provided by crossbow earlier. I am 
> attaching the entire mts400 sensorboard directory to this mail as a 
> zipped folder,in case you may want to have a look at it.
> 
> If there is anything else you may want to know then tell me abt it.
> 
> Thanks
> Ali
> ----------------------------------------------------OUTPUT OF THE MAKE 
> IRIS 
> COMMAND------------------------------------------------------------------
> Mir Murtuza Ali at namreen /opt/MoteWorks/apps/general/GPSSndRec_NC_0.9
> $ make iris
> mkdir -p build/iris
>     compiling GPSRec to a iris binary
> ncc -o build/iris/main.exe -Os -I/opt/MoteWorks/tos/lib/MyLib 
> -finline-limit=100000 -DPLATFORM_M
> ICAZC -I%T/platform/iris -I%T/lib/Queue -I%T/sensorboards/mts400  
> -I%T/lib/Broadcast -I%T/lib/XL
> ib    -DROUTE_PROTOCOL=0x90 -I%T/radio/rf230 -I%T/lib/internal/XMesh 
> -DMULTIHOPROUTER=XMeshRoute
> r -Wall -Wshadow -DDEF_TOS_AM_GROUP=126 -Wnesc-all -target=iris 
> -fnesc-cfile=build/iris/app.c -b
> oard=mts400 -DTOSH_DATA_LENGTH=39 -DTOSH_MAX_TASKS_LOG2=5 
> -DCC2420_TXPOWER=TXPOWER_MAX -DCC2420_
> DEF_CHANNEL=11 -DIDENT_PROGRAM_NAME="GPSRec" 
> -DIDENT_PROGRAM_NAME_BYTES="71,80,83,82,101,99,0" -
> DIDENT_USER_ID="MirMurtuzaAli" 
> -DIDENT_USER_ID_BYTES="77,105,114,77,117,114,116,117,122,97,65,10
> 8,105,0" -DIDENT_HOSTNAME="namreen" 
> -DIDENT_HOSTNAME_BYTES="110,97,109,114,101,101,110,0" -DIDEN
> T_USER_HASH=0xeb22567dL -DIDENT_UNIX_TIME=0x47b49f35L 
> -DRF230_DEF_CHANNEL=11  -DRF230_TXPOWER=TX
> POWER_MAX GPSRec.nc -lm
> In file included from 
> /opt/MoteWorks/tos/sensorboards/mts400/IntersemaPressureM.nc:91,
>                  from 
> /opt/MoteWorks/tos/sensorboards/mts400/IntersemaPressure.nc:81,
>                  from GPSRec.nc:10:
> In component `IntersemaPressureM':
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h: In function `init_debug':
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:17: `U2X' undeclared 
> (first use in this functio
> n)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:17: (Each undeclared 
> identifier is reported onl
> y once
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:17: for each function 
> it appears in.)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:18: `UCSZ1' undeclared 
> (first use in this funct
> ion)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:18: `UCSZ0' undeclared 
> (first use in this funct
> ion)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:20: `TXEN' undeclared 
> (first use in this functi
> on)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h: In function 
> `init_debug_mica2dot':
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:29: `UCSZ1' undeclared 
> (first use in this funct
> ion)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:29: `UCSZ0' undeclared 
> (first use in this funct
> ion)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:31: `TXEN' undeclared 
> (first use in this functi
> on)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h: In function `UARTPutChar':
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:38: `UDRE' undeclared 
> (first use in this functi
> on)
> In file included from 
> /opt/MoteWorks/tos/sensorboards/mts400/GpsPacket.nc:94,
>                  from 
> /opt/MoteWorks/tos/sensorboards/mts400/UARTGpsPacket.nc:81,
>                  from GPSRec.nc:16:
> In component `GpsPacket':
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h: In function `init_debug':
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:17: `U2X' undeclared 
> (first use in this functio
> n)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:18: `UCSZ1' undeclared 
> (first use in this funct
> ion)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:18: `UCSZ0' undeclared 
> (first use in this funct
> ion)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:20: `TXEN' undeclared 
> (first use in this functi
> on)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h: In function 
> `init_debug_mica2dot':
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:29: `UCSZ1' undeclared 
> (first use in this funct
> ion)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:29: `UCSZ0' undeclared 
> (first use in this funct
> ion)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:31: `TXEN' undeclared 
> (first use in this functi
> on)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h: In function `UARTPutChar':
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:38: `UDRE' undeclared 
> (first use in this functi
> on)
> In file included from 
> /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc:81,
>                  from 
> /opt/MoteWorks/tos/sensorboards/mts400/HPLUARTC1.nc:79,
>                  from /opt/MoteWorks/tos/sensorboards/mts400/UART1.nc:75,
>                  from 
> /opt/MoteWorks/tos/sensorboards/mts400/UARTGpsPacket.nc:81,
>                  from GPSRec.nc:16:
> In component `HPLUART1M':
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h: In function `init_debug':
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:17: `U2X' undeclared 
> (first use in this functio
> n)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:18: `UCSZ1' undeclared 
> (first use in this funct
> ion)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:18: `UCSZ0' undeclared 
> (first use in this funct
> ion)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:20: `TXEN' undeclared 
> (first use in this functi
> on)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h: In function 
> `init_debug_mica2dot':
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:29: `UCSZ1' undeclared 
> (first use in this funct
> ion)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:29: `UCSZ0' undeclared 
> (first use in this funct
> ion)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:31: `TXEN' undeclared 
> (first use in this functi
> on)
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h: In function `UARTPutChar':
> /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:38: `UDRE' undeclared 
> (first use in this functi
> on)
> In file included from 
> /opt/MoteWorks/tos/sensorboards/mts400/HPLUARTC1.nc:79,
>                  from /opt/MoteWorks/tos/sensorboards/mts400/UART1.nc:75,
>                  from 
> /opt/MoteWorks/tos/sensorboards/mts400/UARTGpsPacket.nc:81,
>                  from GPSRec.nc:16:
> /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc: In function 
> `UART.init':
> /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc:98: `U2X' undeclared 
> (first use in this func
> tion)
> /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc:101: `UCSZ1' 
> undeclared (first use in this f
> unction)
> /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc:101: `UCSZ0' 
> undeclared (first use in this f
> unction)
> /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc:104: `RXCIE' 
> undeclared (first use in this f
> unction)
> /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc:104: `TXCIE' 
> undeclared (first use in this f
> unction)
> /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc:104: `RXEN' 
> undeclared (first use in this fu
> nction)
> /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc:104: `TXEN' 
> undeclared (first use in this fu
> nction)
> /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc: In function 
> `SIG_UART1_RECV':
> /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc:120: `RXC' 
> undeclared (first use in this fun
> ction)
> /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc: In function `UART.put':
> /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc:131: `TXC' 
> undeclared (first use in this fun
> ction)
> make: *** [exe0] Error 1
> 
> Mir Murtuza Ali at namreen /opt/MoteWorks/apps/general/GPSSndRec_NC_0.9
> $
> 
> On 14/02/2008, *Giri Baleri* <mbaleri at xbow.com 
> <mailto:mbaleri at xbow.com>> wrote:
> 
>     Your error log is missing from your e-mail below.
>     Can you send the complete compile output including the commands you
>     type and the folder you are in?
>      
>     Thanks,
>     Giri
> 
>     ------------------------------------------------------------------------
>     *From:* tinyos-help-bounces at millennium.berkeley.edu
>     <mailto:tinyos-help-bounces at millennium.berkeley.edu>
>     [mailto:tinyos-help-bounces at millennium.berkeley.edu
>     <mailto:tinyos-help-bounces at millennium.berkeley.edu>] *On Behalf Of
>     *Murtuza
>     *Sent:* Thursday, February 14, 2008 10:07 AM
>     *To:* tinyos-help at millennium.berkeley.edu
>     <mailto:tinyos-help at millennium.berkeley.edu>
>     *Subject:* [Tinyos-help] Compilation problem with iris motes....but
>     works finewith micaz
> 
>     Hi Friends
> 
>     I have an application that uses MTS400 GPS sensorboard. Until now I
>     used this application on Micaz motes without any problem. I now
>     decided to switch to IRIS motes as these motes have better
>     transmission power and distance. I installed MoteWorks provided by
>     Crossbow for IRIS support. In MoteWorks when I compiled the
>     application for micaz it compiled without any problem but when I
>     tried compiling for iris it  gave me compile error. The problem is
>     that it cannot detect certain variables from the SODebug.h file
>     present in $TOSROOT/tos/sensorboards/mts400/SODebug.h This mts400 is
>     the one provided by crossbow. I have listed a part of error below.
> 
>     I will really appreciate any help provided.
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
>     Mir Murtuza Ali at namreen /opt/MoteWorks/apps/general/GPSSndRec_NC_0.9
>     $ less file.txt
> 
>     Mir Murtuza Ali at namreen /opt/MoteWorks/apps/general/GPSSndRec_NC_0.9
>     $ make iris
>     mkdir -p build/iris
>         compiling GPSRec to a iris binary
>     ncc -o build/iris/main.exe -Os -I/opt/MoteWorks/tos/lib/MyLib
>     -finline-limit=100000 -DPLATFORM_M
>     ICAZC -I%T/platform/iris -I%T/lib/Queue -I%T/sensorboards/mts400 
>     -I%T/lib/Broadcast -I%T/lib/XL
>     ib    -DROUTE_PROTOCOL=0x90 -I%T/radio/rf230 -I%T/lib/internal/XMesh
>     -DMULTIHOPROUTER=XMeshRoute
>     r -Wall -Wshadow -DDEF_TOS_AM_GROUP=126 -Wnesc-all -target=iris
>     -fnesc-cfile=build/iris/app.c -b
>     oard=mts400 -DTOSH_DATA_LENGTH=39 -DTOSH_MAX_TASKS_LOG2=5
>     -DCC2420_TXPOWER=TXPOWER_MAX -DCC2420_
>     DEF_CHANNEL=11 -DIDENT_PROGRAM_NAME="GPSRec"
>     -DIDENT_PROGRAM_NAME_BYTES="71,80,83,82,101,99,0" -
>     DIDENT_USER_ID="MirMurtuzaAli"
>     -DIDENT_USER_ID_BYTES="77,105,114,77,117,114,116,117,122,97,65,10
>     8,105,0" -DIDENT_HOSTNAME="namreen"
>     -DIDENT_HOSTNAME_BYTES="110,97,109,114,101,101,110,0" -DIDEN
>     T_USER_HASH=0xeb22567dL -DIDENT_UNIX_TIME=0x47b482cbL
>     -DRF230_DEF_CHANNEL=11  -DRF230_TXPOWER=TX
>     POWER_MAX GPSRec.nc -lm
>     In file included from
>     /opt/MoteWorks/tos/sensorboards/mts400/IntersemaPressureM.nc:91,
>                      from
>     /opt/MoteWorks/tos/sensorboards/mts400/IntersemaPressure.nc:81,
>                      from GPSRec.nc:10:
>     In component `IntersemaPressureM':
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h: In function
>     `init_debug':
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:17: `U2X'
>     undeclared (first use in this functio
>     n)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:17: (Each
>     undeclared identifier is reported onl
>     y once
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:17: for each
>     function it appears in.)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:18: `UCSZ1'
>     undeclared (first use in this funct
>     ion)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:18: `UCSZ0'
>     undeclared (first use in this funct
>     ion)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:20: `TXEN'
>     undeclared (first use in this functi
>     on)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h: In function
>     `init_debug_mica2dot':
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:29: `UCSZ1'
>     undeclared (first use in this funct
>     ion)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:29: `UCSZ0'
>     undeclared (first use in this funct
>     ion)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:31: `TXEN'
>     undeclared (first use in this functi
>     on)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h: In function
>     `UARTPutChar':
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:38: `UDRE'
>     undeclared (first use in this functi
>     on)
>     In file included from
>     /opt/MoteWorks/tos/sensorboards/mts400/GpsPacket.nc:94,
>                      from
>     /opt/MoteWorks/tos/sensorboards/mts400/UARTGpsPacket.nc:81,
>                      from GPSRec.nc:16:
>     In component `GpsPacket':
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h: In function
>     `init_debug':
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:17: `U2X'
>     undeclared (first use in this functio
>     n)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:18: `UCSZ1'
>     undeclared (first use in this funct
>     ion)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:18: `UCSZ0'
>     undeclared (first use in this funct
>     ion)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:20: `TXEN'
>     undeclared (first use in this functi
>     on)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h: In function
>     `init_debug_mica2dot':
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:29: `UCSZ1'
>     undeclared (first use in this funct
>     ion)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:29: `UCSZ0'
>     undeclared (first use in this funct
>     ion)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:31: `TXEN'
>     undeclared (first use in this functi
>     on)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h: In function
>     `UARTPutChar':
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:38: `UDRE'
>     undeclared (first use in this functi
>     on)
>     In file included from
>     /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc:81,
>                      from
>     /opt/MoteWorks/tos/sensorboards/mts400/HPLUARTC1.nc:79,
>                      from
>     /opt/MoteWorks/tos/sensorboards/mts400/UART1.nc:75,
>                      from
>     /opt/MoteWorks/tos/sensorboards/mts400/UARTGpsPacket.nc:81,
>                      from GPSRec.nc:16:
>     In component `HPLUART1M':
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h: In function
>     `init_debug':
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:17: `U2X'
>     undeclared (first use in this functio
>     n)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:18: `UCSZ1'
>     undeclared (first use in this funct
>     ion)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:18: `UCSZ0'
>     undeclared (first use in this funct
>     ion)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:20: `TXEN'
>     undeclared (first use in this functi
>     on)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h: In function
>     `init_debug_mica2dot':
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:29: `UCSZ1'
>     undeclared (first use in this funct
>     ion)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:29: `UCSZ0'
>     undeclared (first use in this funct
>     ion)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:31: `TXEN'
>     undeclared (first use in this functi
>     on)
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h: In function
>     `UARTPutChar':
>     /opt/MoteWorks/tos/sensorboards/mts400/SODebug.h:38: `UDRE'
>     undeclared (first use in this functi
>     on)
>     In file included from
>     /opt/MoteWorks/tos/sensorboards/mts400/HPLUARTC1.nc:79,
>                      from
>     /opt/MoteWorks/tos/sensorboards/mts400/UART1.nc:75,
>                      from
>     /opt/MoteWorks/tos/sensorboards/mts400/UARTGpsPacket.nc:81,
>                      from GPSRec.nc:16:
>     /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc: In function
>     `UART.init':
>     /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc:98: `U2X'
>     undeclared (first use in this func
>     tion)
>     /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc:101: `UCSZ1'
>     undeclared (first use in this f
>     unction)
>     /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc:101: `UCSZ0'
>     undeclared (first use in this f
>     unction)
>     /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc:104: `RXCIE'
>     undeclared (first use in this f
>     unction)
>     /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc:104: `TXCIE'
>     undeclared (first use in this f
>     unction)
>     /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc:104: `RXEN'
>     undeclared (first use in this fu
>     nction)
>     /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc:104: `TXEN'
>     undeclared (first use in this fu
>     nction)
>     /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc: In function
>     `SIG_UART1_RECV':
>     /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc:120: `RXC'
>     undeclared (first use in this fun
>     ction)
>     /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc: In function
>     `UART.put':
>     /opt/MoteWorks/tos/sensorboards/mts400/HPLUART1M.nc:131: `TXC'
>     undeclared (first use in this fun
>     ction)
>     make: *** [exe0] Error 1
> 
> 
> 
>     Thanking You
>     Ali
> 
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Tinyos-help mailing list
> Tinyos-help at millennium.berkeley.edu
> https://www.millennium.berkeley.edu/cgi-bin/mailman/listinfo/tinyos-help

-- 
Platform: WinXP/Cygwin
TinyOS version: 1.x, Boomerang
Programmer: MIB510
Device(s): Mica2, MicaZ, Tmote
Sensor board: homebrew



More information about the Tinyos-help mailing list