[Tinyos-help] TOS_Msg length is invalid

Michael Schippling schip at santafe.edu
Mon Feb 11 09:55:55 PST 2008


Under T1 at least the micaz message that comes over the serial line
has been converted to a mica2 format by TOSBase.  This puts the header
fields in the 'wrong' places. Try -comm serial@/dev/ttyS0:mica2
or setting the MOTECOM env variable like that.

might work...
MS


Juan José Roncero wrote:
> Hi everyone!
> 
> I´m working with micaz motes and tinyos-1.x. I´trying to connect them to 
> a middleware application through Serial Forwarder tool but it outputs 
> some errors:
> 
> TOS_Msg length is invalid: header_lenght=265, real_lenght=9 modifying 
> msg to fit
> Received message: FF FF 04 7D 04 00 01 00 01
> 
> I always run SerialForwarder with this command: java 
> net.tinyos.sf.SerialForwarder -comm serial@/dev/ttyS0
> 
> My micaz application was implemented before to being used under 
> Moteworks (windows), but I need to use it under xubunTOS. Is that possible?
> 
> In addition, I`ve tried to use another default application (CountRadio) 
> but it outputs the same error.
> I think it could be a problem with tinyos-1.x configuration, couldn´t it?
> 
> Please, can someone help me?
> 
> Thanks
> 
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Tinyos-help mailing list
> Tinyos-help at millennium.berkeley.edu
> https://www.millennium.berkeley.edu/cgi-bin/mailman/listinfo/tinyos-help

-- 
Platform: WinXP/Cygwin
TinyOS version: 1.x, Boomerang
Programmer: MIB510
Device(s): Mica2, MicaZ, Tmote
Sensor board: homebrew



More information about the Tinyos-help mailing list