[Tinyos-help] TOS_Msg length is invalid

Juan José Roncero estaborn at gmail.com
Mon Feb 11 02:04:47 PST 2008

Hi everyone!

I´m working with micaz motes and tinyos-1.x. I´trying to connect them to a
middleware application through Serial Forwarder tool but it outputs some

TOS_Msg length is invalid: header_lenght=265, real_lenght=9 modifying msg to
Received message: FF FF 04 7D 04 00 01 00 01

I always run SerialForwarder with this command: java
net.tinyos.sf.SerialForwarder -comm serial@/dev/ttyS0

My micaz application was implemented before to being used under Moteworks
(windows), but I need to use it under xubunTOS. Is that possible?

In addition, I`ve tried to use another default application (CountRadio) but
it outputs the same error.
I think it could be a problem with tinyos-1.x configuration, couldn´t it?

Please, can someone help me?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://www.millennium.berkeley.edu/pipermail/tinyos-help/attachments/20080211/f9e19255/attachment.html

More information about the Tinyos-help mailing list