[Tinyos-help] Internal compiler error

Greg Hackmann gwh2 at cse.wustl.edu
Wed Feb 6 09:27:52 PST 2008


Sandip Bapat wrote:
> Hi
>  
> I am trying to compile the default BaseStation app under 
> tinyos-2.x/apps. When I try to compile for 'telosb' I get the following 
> error:
>  
> /BaseStationP.nc: In function `main':
> BaseStationP.nc:102: Internal compiler error in gen_lowpart, at 
> emit-rtl.c:1197
> Please submit a full bug report, with preprocessed source if appropriate./
>  
> The application compiles correctly for mica2, micaz and telosa 
> platforms. Also this is the only app I've come across so far where I get 
> this error. I've checked out the latest CVS code and I've pasted 
> below the dump from tos-check-env (which completes without error) for my 
> compiler versions.
>  
> Is there something I need to upgrade to solve this and if so where can I 
> find it? 
>  
> Thanks
> Sandip

It looks like you have two versions of msp430-gcc installed (one from 
mspgcc-win32tinyos-20041204-2 and one from 
msp430tools-gcc-3.2.3-20050607).  Older versions of msp430-gcc have bugs 
that can cause compiler crashes with some applications.  Try 
uninstalling the mspgcc-win32tinyos package and seeing if that fixes it.

Greg Hackmann


More information about the Tinyos-help mailing list