[Tinyos-help] UART & Radio Simultaneously

Giang Nguyen cauthu at gmail.com
Tue Sep 20 12:24:42 PDT 2005


> 
> Message: 2
> Date: Tue, 20 Sep 2005 09:20:24 -0700 (PDT)
> From: Amit Panchal <panchal_amit21 at yahoo.com>
> Subject: [Tinyos-help] UART & Radio Simultaneously
> To: tinyos-help at Millennium.Berkeley.EDU
> 
> Hi
> 
> I have an application running on a micaz mote, in which the mote receives 
> UART messages from another device and sends the same messages through the 
> radio. Now i am facing a problem with this
> 
> As soon as the UART communication starts it kills the radio communication, 
> the mote which is receiving the the UART message is able to send the message 
> ( I know this because i have set an LED to toggle as soon as it sends any 
> message in the radio message's sendoDone event), i dont know why this is 
> happening.
> I have used the GenericComm component to provide for the radio 
> communication and UARTNoCRCPacket for the UART communication. So i guess the 
> radio and the uart stack are different and they shouldnt mess with each 
> other but i dont know what's wrong. Before introducing the radio part it was 
> receiving the UART messages fine. Please help me regarding this.
> 
> Thanks
> 
> Amit Panchal


i believe that when the microcontroller is busy with UART communication, it 
will not be able to process incoming radio packets.
i had a similar problem when using TOSBase: i was trying to send packets as 
fast as possible, and if the TOSBase does UART forwarding, its reception 
rate is lower than when it does not not do UART forwarding. so, in order to 
see the received packets, i have to save them , and forward UART at a later 
time.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.millennium.berkeley.edu/pipermail/tinyos-help/attachments/20050920/fbcf760d/attachment.htm


More information about the Tinyos-help mailing list