[Tinyos-help] Re: Deluge Simulation on Tossim

boolop at gmail.com boolop at gmail.com
Tue Sep 13 16:42:30 PDT 2005


Hello,
 Are you using deluge 2.0? I've got a similar problem. Could you please let 
me know how you solved it? Thanks very much.
 Best Regards,
Abbot
 On 9/5/05, Sriram Rajan <sr153 at ra.msstate.edu> wrote: 

> My apologies for this earlier post below. But for a rather crazy spam
> filter (somthing with my procmail),I should have realized that the Deluge
> protocol does not require java implementation.
> 
> My special thanks to Mark and Richie for helping me in locating the file
> DelugeStableStoreM.nc and obtaining the desired simulation.
> 
> Thank you.
> 
> Sriram
> 
> On Mon, 5 Sep 2005, Sriram Rajan wrote:
> 
> > I have read the manual on Deluge and performed the following.
> >
> > I have implemented the following mechanism with mica2 mote hardware and
> > the application was transferred completely without hassles. However, I 
> did
> > not have a similar case with TOSSIM simualtion.
> >
> > Please review my TOSSIM setup procedure below and let me know if there 
> are
> > any changes.
> >
> > I have setup my MOTECOM variable to tossim-serial
> >
> > $ export MOTECOM=tossim-serial
> >
> > I have compiled TestDeluge app for pc using 'make pc'.
> >
> > next I started the simulation with the command
> >
> > $ tinyviz -simargs "b=1 l=1.0 s=1" -run build/pc/main.exe 10
> >
> > For booting in one second, real-time and booting with only one mode
> > initially.
> >
> > In another terminal I again set MOTECOM variable to tossim-serial.
> > Enabled to run Deluge with component DelugeC included and 
> Main.StdControl
> > -> DelugeC; and then I compiled the SenseToRfm program for mica2.
> >
> > Then I attempt to inject this image to the simulator running TestDeluge
> > using :
> >
> > $ java net.tinyos.tools.Deluge -i -in 0 -if build/mica2/main.ihex
> >
> > It shows connected but does not display any progress. The simulator
> > displays the AM_Address messages with counters updated for the messages
> > from the injector. However, these messages do not reach the mote 0
> > connected to simulator using tossim-serial.
> >
> > Please let me know if I am mistaken.
> >
> > Thank you.
> >
> > Sriram
> >
> >
> _______________________________________________
> Tinyos-help mailing list
> Tinyos-help at Millennium.Berkeley.EDU
> https://mail.millennium.berkeley.edu/cgi-bin/mailman/listinfo/tinyos-help
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.millennium.berkeley.edu/pipermail/tinyos-help/attachments/20050913/59775181/attachment.html


More information about the Tinyos-help mailing list