[Tinyos-help] Ice-gdb error with JTAGMKII

=?ks_c_5601-1987?B?uenBvri4?= jmbaek at innors.com
Thu Sep 8 19:16:56 PDT 2005


Hello, Just got the new JTAGICE-MKII and attempted to use it on a couple of sampletinyos apps. Unfortunately, I cannot connect mote through JTAG.I did test it with AVR studio 4.11 which is working (means I can downloadblink application through it and see blinks) Could anyone help me figure itout? Here is error message I've got (Actually I tried with Windows and Linux, butthe same error occurs): =========================================================[Administrator at baek]#/opt/tinyos-1.x/apps/Blink$  make clean; make micaz debugrm -rf buildmkdir -p build/micaz    compiling Blink to a micaz binaryncc -o build/micaz/main.exe -Os -O1 -g -fnesc-no-inline -finline-limit=100000  -Wall -Wshadow -DDEF_TOS_AM_GROUP=0x7d -Wnesc-all -target=micaz -fnesc-cfile=build/micaz/app.c -board=micasb -DIDENT_PROGRAM_NAME="Blink"  -DIDENT_USER_ID="Administrator"-I/opt/tinyos-1.x/tos/lib/CC2420Radio Blink.nc -lm     compiled Blink to build/micaz/main.exe            2572 bytes in ROM              48 bytes in RAMavr-objcopy --output-target=srec build/micaz/main.exe build/mica2/main.srecavr-objcopy --output-target=srec build/micaz/main.exe build/mica2/main.ihex          writing TOS image[Administrator at baek]#/opt/tinyos-1.x/apps/Blink$  export AVARICE_ARGS='-j /dev/ttyS0' [Administrator at baek]#/opt/tinyos-1.x/apps/Blink$ ice-gdb build/mica2/main.exe AVaRICE version 2.0.20030825cvs, Aug 26 2003 03:14:15 JTAG config starting.Failed to synchronise with the JTAG ICE (is it connected and powered?)GNU gdb cvs-pre6.0-tinyos Copyright 2003 Free Software Foundation, Inc. GDB isfree software, covered by the GNU General Public License, and you arewelcome to change it and/or distribute copies of it under certainconditions. Type "show copying" to see the conditions. There is absolutelyno warranty for GDB.  Type "show warranty" for details. This GDB wasconfigured as "--host=i686-pc-linux-gnu --target=avr".../usr/local/share/avarice/gdb-avarice-script:26: Error in sourced commandfile:localhost:6423: Connection refused.(gdb) ============================================== Anyone else trying these new products out with any success? Suggestionsappreciated!  Baek 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.millennium.berkeley.edu/pipermail/tinyos-help/attachments/20050909/bb15d4c7/attachment.htm


More information about the Tinyos-help mailing list