[Tinyos-help] toscheck problem

Kristin Wright l.kristin.wright at gmail.com
Thu Mar 24 05:47:43 PST 2005


Nah -- they're not related. You may not need . in your path --  it's
there for historical purposes. But at least you understand the issue
there so let's move on.

My guess on the flash errors is that you're not using the right 'make'
commands for your programmer. The flash errors only come up when
you're using a parallel port programming board with the product name
mib500. Most folks are either using the mib510 or none at all (the
telos family programs through the USB port and doesn't need a
programming board).

Consult the Getting Started guide for whatever mote you're using. Both
Crossbow and Telos offer Getting Started guides on their web sites.
The command you should look for would be something like this:

make micaz install,1 mib510,COM1 


On Mon, 21 Mar 2005 18:14:20 -0500, Khoa Nguyen <khoanguyen81 at gmail.com> wrote:
> Hi all,
> 
> After installing tinyOS1.1.0, I ran the toscheck and there were no
> errors. I then update the latest cygwin package cygwin-1.2a.tar, and
> install the latest nesc: nesc-1.1.2b-1.cygwin.i386.rpm, and
> tinyos-1.1.11Feb2005cvs-1.cygwin.noarch.rpm. I then ran the toscheck
> again and receive 1 error about classpath. "WARNING: CLASSPATH may not
> incluce '.' <that is, the symbol for the current working directory>.
> Please add '.' to your CLASSPATH or you may experience configuration
> problems." I then ran the hardware check and ran into problem about
> "flash error." Are these two problems related? How would I solve them?
> I ran the "echo $CLASSPATH" command, and here is the beginning of it:
> ".\;C:\tinyos\cygwin\opt\tinyos-1.x\tools\java;....." Please advise.
> Thnx.
> 
> Ray
> _______________________________________________
> Tinyos-help mailing list
> Tinyos-help at Millennium.Berkeley.EDU
> http://mail.Millennium.Berkeley.EDU/mailman/listinfo/tinyos-help
>


More information about the Tinyos-help mailing list