[Tinyos-help] MIB 510 running problem

Harri Siirtola harri.siirtola at vtt.fi
Fri Mar 18 00:26:07 PST 2005


Hi,

make sure that SW2 is set to "OFF" on MIB510.

At 10:23 17.3.2005 -0800, ashok sahu wrote:
>Hi All,
>
>            I am using MIB510 borad... did toscheck... its fine... after 
> that I tried doing hardware verification.... got flash error as usual... 
> tried things mentioned in this mailing list...
>
>Particularly this mail was helpful...
>
>Hi,
>If you see the below carefully, you have a line,
> > uisp -dprog=dapa -dpart=ATmega128 --wr_fuse_e=ff  --erase
>where "-dprog=dapa" means that you are trying to
>install on MIB500 using parallel port.
>I guess that you are using the 'old' make system.
>Try,
>"make mica2 install MIB510=/dev/ttyS0"
>If you want to use the 'new' make system,
>export 'MAKERULES' as in the previous email,
>and do "make mica2 install mib510,/dev/ttyS0"
>Note that the "MIB510=" and "mib510," are different.
>but now even though I am not getting flash error... this is what i get
>
>/opt/tinyos-1.x/apps/MicaHWVerify
>$ make mica2 install MIB510=/dev/ttyS0
>     compiling MicaHWVerify to a mica2 binary
>ncc -o build/mica2/main.exe -Os -board=micasb -target=mica2  -Wall 
>-Wshadow -DDE
>F_TOS_AM_GROUP=0x7d -Wnesc-all -finline-limit=100000 
>-fnesc-cfile=build/mica2/ap
>p.c  MicaHWVerify.nc -lm
>     compiled MicaHWVerify to build/mica2/main.exe
>            10156 bytes in ROM
>              386 bytes in RAM
>avr-objcopy --output-target=srec build/mica2/main.exe build/mica2/main.srec
>make[1]: Entering directory `/opt/tinyos-1.x/apps/MicaHWVerify'
>     installing mica2 binary
>uisp -dprog=mib510 -dserial=/dev/ttyS0 -dpart=ATmega128 
>--wr_fuse_e=ff  --erase
>--upload  if=build/mica2/main.srec
>Programmer is not responding.
>make[1]: *** [reins! tall] Error 2
>make[1]: Leaving directory `/opt/tinyos-1.x/apps/MicaHWVerify'
>make: *** [install] Error 2
>
>
>Could any body tell me whats the problem?
>
>Thanks
>Ashok
>
>
>
>Do you Yahoo!?
>_______________________________________________
>Tinyos-help mailing list
>Tinyos-help at Millennium.Berkeley.EDU
>http://mail.Millennium.Berkeley.EDU/mailman/listinfo/tinyos-help



More information about the Tinyos-help mailing list