[Tinyos-help] Problem getting temperature on Telos Rev A

Joe Polastre joe.polastre at gmail.com
Wed Mar 16 10:32:09 PST 2005


Hi Pedro,

  Great, glad you got it working.  I'm cc'ing this to tinyos-help for
the archives in case others have the same problem.

-Joe


On Wed, 16 Mar 2005 18:10:05 +0100, Pedro M. Ruiz <pedrom at dif.um.es> wrote:
>  Hi Joe!
>  
>  Thanks a lot to both of you,
>  
>  I'll try applying the patches... In any case I think you are rigth. I am
> currently using DemoSensorC, which I believe it is associated to the
> Internal temperature sensor...
>  
>  Thus, according to Telos datasheet maps to 12,23 Celsius, which is pretty
> much the temperature I was expecting.
>  
>  Regards,
>  
>  --Pedro
> 
>  
>  Joe Polastre wrote: 
>  Pedro, You should upgrade to tinyos 1.1.11 and then apply the HPLUSART
> patch indicated on the webpage
> http://www.tinyos.net/scoop/story/2005/2/28/95258/3519 Are you using the
> InternalTemperature sensor or the Sensirion Humidity/Temperature sensor. It
> looks like you're apply the formula from the Sensirion sensor but actually
> sampling the Internal MSP430 Temperature sensor. -Joe On Wed, 16 Mar 2005
> 12:50:14 +0100, Inés C.M <ines.cabrera at gmail.com> wrote: 
>  Hello Pedro, I'm not very sure about Telos rev A, but as far as I know you
> can't use the Oscilloscope in apps/ for Telos, for some issues with the ADC.
> In that case, you are likely to get strange readings, such as 0AFB for
> temperature. I recommend you to use contrib/moteiv/apps/Oscilloscope. It
> didn't work for me at the beginning, but remember to check all the bug fixes
> in the TinyOS CVS (I believe that the moteiv distribution does not have the
> latest for many Telos modules). BR, On Wed, 16 Mar 2005 12:30:34 +0100,
> Pedro M. Ruiz <pedrom at dif.um.es> wrote: 
>  Hi, I know there was a similar message three months ago, but I haven´t
> found the answer posted on the list. May be you can give me some hint. I use
> the oscilloscope application in /opt/tinyos-1.x/apps/ and everything seems
> to work fine. Howerver, the "Listen" applications is getting readings which
> seem unlikely for temperatures. 1A 00 00 00 00 00 7E 00 0A 7D 01 00 22 01 01
> 00 EB 0A F3 0A FB 0A EB 0A FB 0A 02 0B EB 0A EB 0A FB 0A FB 0A When I
> convert 0AFB to Celsius using -39.6+0.01*(2811) I get -11.49 which
> fortunately for my health is not my office temperature. I also tried to
> compile Oscilloscope applicaton in /opt/tinyos-1.x/contrib/moteiv/apps/ but
> it does not compile. ncc blames HPLUSART0M.nc for not having "enableI2C" and
> "disableI2C" in interfaces USASRTControl. I am using latest autoinstall
> version for windows from moteiv. Thanks in advance for your help. --Pedro
> _______________________________________________ Tinyos-help mailing list
> Tinyos-help at Millennium.Berkeley.EDU
> http://mail.Millennium.Berkeley.EDU/mailman/listinfo/tinyos-help
> _______________________________________________ Tinyos-help mailing list
> Tinyos-help at Millennium.Berkeley.EDU
> http://mail.Millennium.Berkeley.EDU/mailman/listinfo/tinyos-help
> _______________________________________________ Tinyos-help mailing list
> Tinyos-help at Millennium.Berkeley.EDU
> http://mail.Millennium.Berkeley.EDU/mailman/listinfo/tinyos-help 
>


More information about the Tinyos-help mailing list