[Tinyos-help] Humidity sensors and multihop

Inés C.M ines.cabrera at gmail.com
Fri Mar 11 11:36:13 PST 2005


Hi!

Yes, I have run SurgeTelos, I have succesfully changed the source of
data to light (TSR and PAR) sensors, as well as internal temperature
and voltage, I have been running the java surge tool and checked that
I can receive correct data from all the motes, and that the multihop
tree builds properly. It is just when I try to use HumidityC and
initialise it (call HumidityControl.init();), as done in
moteiv/apps/Oscilloscope, that although all the motes are sending
data, SerialForwarder just receives data from the mote with address 0
(attached to the PC). I initialise it in StdControl.init(), as done in
Oscilloscope.

Sorry for being so persistent, but I just don't know what else to
try... I have reviewed it so many times, that I think by now I know
the code by heart :)

Inés.


On Fri, 11 Mar 2005 11:24:12 -0800, Joe Polastre <joe.polastre at gmail.com> wrote:
> Hi Ines,
> 
>   Have you successfully run the unmodified version of SurgeTelos?
> Have you followed the directions to correctly build the java classes
> in tinyos-1.x/contrib/ucb/apps/SurgeTelos/README
> 
> -Joe
> 
> 
> On Fri, 11 Mar 2005 11:23:01 +0100, Inés C.M <ines.cabrera at gmail.com> wrote:
> > Hi again,
> >
> > Has anyone succesfully used the Humidity and/or temperature sensors in
> > Telos b along with the multihop routing? I really don´t know what else
> > to chack, and still it does not work... has this ever been tested
> > before? Is there any other place where I could post this question?
> >
> > Thanks a lot,
> > Inés
> > _______________________________________________
> > Tinyos-help mailing list
> > Tinyos-help at Millennium.Berkeley.EDU
> > http://mail.Millennium.Berkeley.EDU/mailman/listinfo/tinyos-help
> >
>


More information about the Tinyos-help mailing list