[Tinyos-help] could not find the javax.comm classes.....

Kristin Wright l.kristin.wright at gmail.com
Fri Mar 11 10:41:24 PST 2005


toscheck checks for the existence of the java xcomm libraries by
building a test java class with a javax comm class and ensuring that
javac can compile it. If javac can't find that class, the test fails.

So I'm guessing that you do have it, but the java binaries that are
getting invoked on your system isn't the one that our tinyos installer
installer. To check if this is the case, type 'which java' and make
sure that the result is something that comes from the installed tinyos
directories:

$ which java
/cygdrive/c/jdk1.4.1_02/j2sdk1.4.1_02/bin/java'

and not something from WINNT or some other previously installed java.

-kw

On Fri, 11 Mar 2005 09:01:02 -0800 (PST), Vijay Achanti
<vjachanti at yahoo.com> wrote:
> Hi,
> 
> I am installing tinyOS on a new machine and having
> problems with the installation.  I have installed
> tinyos1.1.0 from the crossbow CD and then upgraded it
> to tinyos1.1.7 by installing
> tinyos-1.1.7July2004cvs-2.cygwin.noarch.rpm.  After
> that when I ran toscheck, and it is giving the
> following error
> -->WARNING: Could not find the javax.comm classes.
> Please ensure the java comm API is installed
> correctly.
> I did the same kind of installation previously on
> another machine and it worked perfectly.  Any help
> will be greatly appreciated.  Thank You.
> 
> Sincerely,
> 
> VJ
> 
> __________________________________
> Do you Yahoo!?
> Yahoo! Small Business - Try our new resources site!
> http://smallbusiness.yahoo.com/resources/
> _______________________________________________
> Tinyos-help mailing list
> Tinyos-help at Millennium.Berkeley.EDU
> http://mail.Millennium.Berkeley.EDU/mailman/listinfo/tinyos-help
>


More information about the Tinyos-help mailing list