[Tinyos-help] flash errors on mib510

Jeongyeup Paek jpaek at usc.edu
Fri Mar 4 04:20:53 PST 2005


Hi,

If you see the below carefully, you have a line,

> uisp -dprog=dapa -dpart=ATmega128 --wr_fuse_e=ff  --erase

where "-dprog=dapa" means that you are trying to
install on MIB500 using parallel port.

I guess that you are using the 'old' make system.
Try,
"make mica2 install MIB510=/dev/ttyS0"

If you want to use the 'new' make system,
export 'MAKERULES' as in the previous email,
and do "make mica2 install mib510,/dev/ttyS0"

Note that the "MIB510=" and "mib510," are different.

Thanks.


Jeongyeup Paek

Graduate Student at
Electrical Engineering Department
University of Southern California /
Embedded Networks Laboratory
Computer Science Department
University of Southern California.

--


CHEN Quanbin wrote:
> Dear all,
> 	
> 	I've got a MIB 510 programming board, and I have been working on it for several days. However, I always get the flash errors when programming. I have tried it both on my laptop (IBM T42, WinXP) and on my desktop (WinXP), but it can't work at all. What is more, I have nearly read all the prior postings in the archives, trying several commands, such as "make mica2 install mib510,COM1", "make mica2 install mib510,/dev/ttyS0", "mib510=/dev/ttyS0 make install mica2" and "mib510=COM1 make install mica2". Could anyone give me a solution to this? Any help would be appreciated! Thanks
> 
>    The error is something like this:
> -----------------------------------------------------------------------------------------------------------
> make mica2 install mib510,/dev/ttyS0
>     compiling CntToLeds to a mica2 binary
> ncc -o build/mica2/main.exe -Os -board=micasb -target=mica2 -I%T/lib/Counters -Wall -Wshadow -DDEF_TOS_AM_GROUP=0x7d -Wnesc-all -finline-limit=100000 -fnesc-cfile=build/mica2/app.c  CntToLeds.nc -lm 
>     compiled CntToLeds to build/mica2/main.exe
>             1570 bytes in ROM
>               46 bytes in RAM
> avr-objcopy --output-target=srec build/mica2/main.exe build/mica2/main.srec
> make[1]: Entering directory `/opt/tinyos-1.x/apps/CntToLeds'
>     installing mica2 binary
> uisp -dprog=dapa -dpart=ATmega128 --wr_fuse_e=ff  --erase 
> pulse
> Atmel AVR ATmega128 is found.
> Erasing device ...
> pulse
> Reinitializing device
> Atmel AVR ATmega128 is found.
> 
> Fuse Extended Byte set to 0xff
> sleep 1	     
> uisp -dprog=dapa -dpart=ATmega128 --wr_fuse_e=ff  --upload if=build/mica2/main.srec
> pulse
> Atmel AVR ATmega128 is found.
> Uploading: flash
> 
> Fuse Extended Byte set to 0xff
> sleep 1	     
> uisp -dprog=dapa -dpart=ATmega128 --wr_fuse_e=ff  --verify if=build/mica2/main.srec
> pulse
> Atmel AVR ATmega128 is found.
> Uploading: flash
> flash error at address 0x0: file=0x0c, mem=0x00
> flash error at address 0x1: file=0x94, mem=0x00
> flash error at address 0x2: file=0x46, mem=0x00
> flash error at address 0x3: file=0x0c, mem=0x00
> ......
> ......
> ......
> -----------------------------------------------------------------------------------------------------------------------
> 
> Best regards, 
> Sam.
> 2005-03-04
> 
> 
> _______________________________________________
> Tinyos-help mailing list
> Tinyos-help at Millennium.Berkeley.EDU
> http://mail.Millennium.Berkeley.EDU/mailman/listinfo/tinyos-help


More information about the Tinyos-help mailing list