[Tinyos-devel] again about the baudrate issue for telos

Stephen Dawson-Haggerty stevedh at eecs.berkeley.edu
Mon Feb 16 13:26:35 PST 2009


Everybody seems to have agreed that the default msp430 uart speed should be
57600-- can somebody in core make the change?  It is definitely much more
reliable at the slower baud rate...

Best,
Steve


On Thu, Sep 4, 2008 at 11:05 AM, Andreas Köpke <koepke at tkn.tu-berlin.de>wrote:

>
>
> > What I've observed is the receive code is too long period.  So that
> > bytes get missed in the incoming stream.  This
> > depends somewhat on what else is going on in the system but can be
> > replicated fairly easily.  I found 57600 was
> > pretty solid and didn't have time to futher dig into it.  Keep in mind
> > I'm using threads and so have thread checks on
> > the end of the lowest level of interrupt code too.
> >
> > It doesn't seem to depend on outgoing traffic.  In my test case there
> > is none.
> >
> > The easy thing to do is to just make the default 57600 so other folks
> > have a reasonably quick but stable starting
> > point.
> >
> >
> > eric
> >
>
> I agree -- everything else is much more complicated.
>
> Best, Andreas
>
> _______________________________________________
> Tinyos-devel mailing list
> Tinyos-devel at millennium.berkeley.edu
> https://www.millennium.berkeley.edu/cgi-bin/mailman/listinfo/tinyos-devel
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://www.millennium.berkeley.edu/pipermail/tinyos-devel/attachments/20090216/e59d733f/attachment.htm 


More information about the Tinyos-devel mailing list